首頁 股票學校 股票入門 選股 買入 看盤 跟莊 短線 炒股技巧 技術指標 k線圖 MACD 均線 成交量 股票書籍 股票視頻 網站導航

767股票學習網 > 股票學校 > 大智慧公式 > 正文

大智慧、飛狐公式:安心操作--回抽支撐

【安心操作--回抽支撐】主副圖 (原碼)

精品[回抽支撐],指標編寫思路:1、趨勢向上:支撐均線保持向上,安全操作;2、多頭排列:均線系統成多頭發散排列,形成上級保障;3、站穩均線:股價連續站在指定均線之上達到一定日期;4、回抽均線:股價在滿足1、2、3的基礎上,最低價或者收盤價回靠、下穿某均線,視為回抽;5、買點確定:當股價回抽均線距離在2%之內,確定為回抽買點。
指標信號與使用技巧:
1、指標信號:回抽均線,分別以同顏色的數字⊙②③④⑤⑥,在該均線位置表示;
2、短期優選:短期均線的回抽信號越有價值;3、首次優選:同一均線的回抽買點信號,短期內首次出現優選;再次出現選擇放棄,關注下一均線支撐買點;4、多頭優選:均線多頭排列越順暢的優選;5、買點把握:買點設定為回抽均線,故盤中買點最好買在盤中股價打到均線+-2%附近時,盤中明顯下跌動能有所減弱時及時跟進,---注意盡量買在均線附近,盤中切記不可追漲!6、獲利把握:買點后三日,一般應有反彈行情出現;如短期已經有明顯回抽買點與反彈波段出現,此時的回抽也許會變成破位走弱,應該適當回避。{優選思路:短線趨勢向上+連續縮量+WR指標超跌}短線交易--威連指標參考}
{回抽支撐,弱市專用!大智慧副圖指標}{飛狐通用}
WR1:=100*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10));
WR2:=100*(HHV(HIGH,6)-CLOSE)/(HHV(HIGH,6)-LLV(LOW,6));
漲:WR2<10,POINTDOT,COLORRED;
跌:WR2>80,POINTDOT,COLORWHITE;
DRAWTEXT(漲>0 ,7 , '$'),COLORRED;
DRAWTEXT(跌>0 ,1 , '#'),COLORWHITE;
P1:=5;P2:=10;P3:=20;P4:=30;P5:=60;P6:=120;
MA1:=MA(C,P1),COLORYELLOW;
MA2:=MA(C,P2),COLORFF00FF;
MA3:=MA(C,P3),COLOR00FF00;
MA4:=MA(C,P4),COLORWHITE;
MA5:=MA(C,P5),COLORFF9900;
MA6:=MA(C,P6),COLOR0000FF;
{ENV軌道線支撐}
UPPER:=(1+6/100)*MA(CLOSE,25);
LOWER:=(1-6/100)*MA(CLOSE,25);
MID:=(UPPER+LOWER)/2,COLORYELLOW,LINETHICK2;
生命線:=MID,COLORYELLOW,POINTDOT,LINETHICK2;
DTPLENV:=COUNT(MID>REF(MID,1),5)=5;
回:=((CROSS(MID,L) OR CROSS(MID,C)) AND DTPLENV)*1,COLORYELLOW,POINTDOT;
{MA2支撐}
QSXS2:=MA2>=REF(MA2,1);
DTPL2:=MA1>MA2 AND MA2>MA3 AND MA3>MA4;
ZWP2:=COUNT(C>MA2,P1)=P1 AND DTPL2;
HCP2A:=CROSS(MA2*1.02,L) AND REF(ZWP2,1);
HCP2B:=CROSS(MA2,C) AND REF(ZWP2,1);
回2:=((HCP2A OR HCP2B) AND QSXS2 AND DTPL2)*3,COLOR00FF00,POINTDOT;
{MA3支撐}
QSXS3:=MA3>=REF(MA3,1);
DTPL3:=MA1>MA2 AND MA2>MA3 AND MA3>MA4;
ZWP3:=COUNT(C>MA3,P1)=P1 AND DTPL3;
HCP3A:=CROSS(MA3*1.03,L) AND REF(ZWP3,1);
HCP3B:=CROSS(MA3,C) AND REF(ZWP3,1);
回3:=((HCP3A OR HCP3B) AND QSXS3)*3,COLOR00FF00,POINTDOT;
{MA4支撐}
QSXS4:=MA4>=REF(MA4,1);
DTPL4:=MA2>MA3 AND MA3>MA4 AND MA4>MA5;
ZWP4:=COUNT(C>MA4,P2)=P2 AND DTPL4;
HCP4A:=CROSS(MA4*1.04,L) AND REF(ZWP4,1);
HCP4B:=CROSS(MA4*1.02,C) AND REF(ZWP4,1);
回4:=((HCP4A OR HCP4B) AND QSXS4)*4,COLORWHITE,POINTDOT;
{MA5支撐}
QSXS5:=MA5>=REF(MA5,1);
DTPL5:=MA3>MA4 AND MA4>MA5 AND MA5>MA6;
ZWP5:=COUNT(C>MA5,P3)=P3 AND DTPL5;
HCP5A:=CROSS(MA5*1.05,L) AND REF(ZWP5,1);
HCP5B:=CROSS(MA5*1.02,C) AND REF(ZWP5,1);
回5:=((HCP5A OR HCP5B) AND QSXS5)*5,COLORFF9900,POINTDOT;
{MA6支撐}
QSXS6:=MA6>=REF(MA6,1);
DTPL6:=MA5>MA6;
ZWP6:=COUNT(C>MA6,P3)=P3 AND DTPL6;
HCP6A:=CROSS(MA6*1.05,L) AND REF(ZWP6,1);
HCP6B:=CROSS(MA6*1.02,C) AND REF(ZWP6,1);
回6:=((HCP6A OR HCP6B) AND QSXS6)*6,COLORRED,POINTDOT;
買:COUNT(回>0,2)>=1 AND ABS(L/MID-1)*100<=2,COLORYELLOW,POINTDOT;
買2:COUNT(回2>0,2)>=1 AND ABS(L/MA2-1)*100<=2,COLORFF00FF,POINTDOT;
買3:COUNT(回3>0,2)>=1 AND ABS(L/MA3-1)*100<=2,COLOR00FF00,POINTDOT;
買4:COUNT(回4>0,2)>=1 AND ABS(L/MA4-1)*100<=2,COLORWHITE,POINTDOT;
買5:COUNT(回5>0,2)>=1 AND ABS(L/MA5-1)*100<=2,COLORFF9900,POINTDOT;
買6:COUNT(回6>0,2)>=1 AND ABS(L/MA6-1)*100<=2,COLORRED,POINTDOT;
MBZ:=買 OR 買2 OR 買3 OR 買4 OR 買5 OR 買6;
QSXS:=DTPL4 AND MA3>REF(MA3,1) AND MA4>REF(MA4,1);
YX:=跌 AND MBZ AND QSXS AND COUNT(V<REF(V,1),4)>=2 AND COUNT(C<REF(C,1),3)
>=2;
優選:(YX OR (REF(YX,1) AND C<REF(C,1)))*5,COLOR00FF00;
{以下設置副圖顯示方式}
1,POINTDOT,COLORYELLOW;
2,POINTDOT,COLORFF00FF;
3,POINTDOT,COLOR00FF00;
4,POINTDOT,COLORWHITE;
5,POINTDOT,COLORFF9900;
6,POINTDOT,COLORRED;
7,POINTDOT,color00FF00;
STICKLINE(買>0,1,2,4,0),COLORYELLOW;
STICKLINE(買2>0,2,3,4,0),COLORFF00FF;
STICKLINE(買3>0,3,4,4,0),COLOR00FF00;
STICKLINE(買4>0,4,5,4,0),COLORWHITE;
STICKLINE(買5>0,5,6,4,0),COLORFF9900;
STICKLINE(買6>0,6,7,4,0),COLORRED;
DRAWTEXT(回>0 ,1 , '⊙'),COLORYELLOW;
DRAWTEXT(回2>0 ,2 , '②'),COLORFF00FF;
DRAWTEXT(回3>0 ,3 , '③'),COLOR00FF00;
DRAWTEXT(回4>0 ,4 , '④'),COLORWHITE;
DRAWTEXT(回5>0 ,5 , '⑤'),COLORFF9900;
DRAWTEXT(回6>0 ,6 , '⑥'),COLORRED;
{以下設置主圖顯示方式}
{DRAWTEXT(回>0 ,MID , '⊙'),COLORYELLOW;
DRAWTEXT(回2>0 ,MA2 , '②'),COLORFF00FF;
DRAWTEXT(回3>0 ,MA3 , '③'),COLOR00FF00;
DRAWTEXT(回4>0 ,MA4 , '④'),COLORWHITE;
DRAWTEXT(回5>0 ,MA5 , '⑤'),COLORFF9900;
DRAWTEXT(回6>0 ,MA6 , '⑥'),COLORRED;
DRAWTEXT(買>0 ,L*0.99 , '★'),COLORYELLOW;
DRAWTEXT(買2>0 ,L*0.98 , '□'),COLORFF00FF;
DRAWTEXT(買3>0 ,L*0.99 , '▲'),COLOR00FF00;
DRAWTEXT(買4>0 ,L*0.98 , '◆'),COLORWHITE;
DRAWTEXT(買5>0 ,L*0.99 , '■'),COLORFF9900;
DRAWTEXT(買6>0 ,L*0.98 , '●'),COLORRED;
支撐點:IF(COUNT(ZC3>0,5),REF(L,HCSJ3),REF(L,HCSJ3)),
COLOR00FF00,POINTDOT,linethick1;}
{回抽支撐Z----一品茶緣編寫,弱市專用!大智慧主圖指標} {飛狐通用}
WR1:=100*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10));
WR2:=100*(HHV(HIGH,6)-CLOSE)/(HHV(HIGH,6)-LLV(LOW,6));
漲:=WR2<10,POINTDOT,COLORRED;
跌:=WR2>80,POINTDOT,COLORWHITE;
DRAWTEXT(漲>0 ,H*1.02 , '$'),COLORRED;
DRAWTEXT(跌>0 ,L*0.98 , '#'),COLORWHITE;
P1:=5;P2:=10;P3:=20;P4:=30;P5:=60;P6:=120;
MA1:MA(C,P1),COLORYELLOW;
MA2:MA(C,P2),COLORFF00FF;
MA3:MA(C,P3),COLOR00FF00;
MA4:MA(C,P4),COLORWHITE;
MA5:MA(C,P5),COLORFF9900;
MA6:MA(C,P6),COLOR0000FF;
{ENV軌道線支撐}
UPPER:=(1+6/100)*MA(CLOSE,25);
LOWER:=(1-6/100)*MA(CLOSE,25);
MID:=(UPPER+LOWER)/2,COLORYELLOW,LINETHICK2;
生命線:MID,COLORYELLOW,POINTDOT,LINETHICK2;
DTPLENV:=COUNT(MID>REF(MID,1),5)=5;
回:=((CROSS(MID,L) OR CROSS(MID,C)) AND DTPLENV)*1,COLORYELLOW,POINTDOT;
{MA2支撐}
QSXS2:=MA2>=REF(MA2,1);
DTPL2:=MA1>MA2 AND MA2>MA3 AND MA3>MA4;
ZWP2:=COUNT(C>MA2,P1)=P1 AND DTPL2;
HCP2A:=CROSS(MA2*1.02,L) AND REF(ZWP2,1);
HCP2B:=CROSS(MA2,C) AND REF(ZWP2,1);
回2:=((HCP2A OR HCP2B) AND QSXS2 AND DTPL2)*3,COLOR00FF00,POINTDOT;
{MA3支撐}
QSXS3:=MA3>=REF(MA3,1);
DTPL3:=MA1>MA2 AND MA2>MA3 AND MA3>MA4;
ZWP3:=COUNT(C>MA3,P1)=P1 AND DTPL3;
HCP3A:=CROSS(MA3*1.03,L) AND REF(ZWP3,1);
HCP3B:=CROSS(MA3,C) AND REF(ZWP3,1);
回3:=((HCP3A OR HCP3B) AND QSXS3)*3,COLOR00FF00,POINTDOT;
{MA4支撐}
QSXS4:=MA4>=REF(MA4,1);
DTPL4:=MA2>MA3 AND MA3>MA4 AND MA4>MA5;
ZWP4:=COUNT(C>MA4,P2)=P2 AND DTPL4;
HCP4A:=CROSS(MA4*1.04,L) AND REF(ZWP4,1);
HCP4B:=CROSS(MA4*1.02,C) AND REF(ZWP4,1);
回4:=((HCP4A OR HCP4B) AND QSXS4)*4,COLORWHITE,POINTDOT;
{MA5支撐}
QSXS5:=MA5>=REF(MA5,1);
DTPL5:=MA3>MA4 AND MA4>MA5 AND MA5>MA6;
ZWP5:=COUNT(C>MA5,P3)=P3 AND DTPL5;
HCP5A:=CROSS(MA5*1.05,L) AND REF(ZWP5,1);
HCP5B:=CROSS(MA5*1.02,C) AND REF(ZWP5,1);
回5:=((HCP5A OR HCP5B) AND QSXS5)*5,COLORFF9900,POINTDOT;
{MA6支撐}
QSXS6:=MA6>=REF(MA6,1);
DTPL6:=MA5>MA6;
ZWP6:=COUNT(C>MA6,P3)=P3 AND DTPL6;
HCP6A:=CROSS(MA6*1.05,L) AND REF(ZWP6,1);
HCP6B:=CROSS(MA6*1.02,C) AND REF(ZWP6,1);
回6:=((HCP6A OR HCP6B) AND QSXS6)*6,COLORRED,POINTDOT;
買:=COUNT(回>0,2)>=1 AND ABS(L/MID-1)*100<=2,COLORYELLOW,POINTDOT;
買2:=COUNT(回2>0,2)>=1 AND ABS(L/MA2-1)*100<=2,COLORFF00FF,POINTDOT;
買3:=COUNT(回3>0,2)>=1 AND ABS(L/MA3-1)*100<=2,COLOR00FF00,POINTDOT;
買4:=COUNT(回4>0,2)>=1 ANDABS(L/MA4-1)*100<=2,COLORWHITE,POINTDOT;
買5:=COUNT(回5>0,2)>=1 AND ABS(L/MA5-1)*100<=2,COLORFF9900,POINTDOT;
買6:=COUNT(回6>0,2)>=1 AND ABS(L/MA6-1)*100<=2,COLORRED,POINTDOT;
MBZ:=買 OR 買2 OR 買3 OR 買4 OR 買5 OR 買6;
QSXS:=DTPL4 AND MA3>REF(MA3,1) AND MA4>REF(MA4,1);
YX:=跌 AND MBZ AND QSXS AND COUNT(V<REF(V,1),4)>=2 AND COUNT(C<REF(C,1),3)
>=2;
優選:=(YX OR (REF(YX,1) AND C<REF(C,1)))*5,COLOR00FF00;
{以下設置副圖顯示方式}
{1,POINTDOT,COLORYELLOW;
2,POINTDOT,COLORFF00FF;
3,POINTDOT,COLOR00FF00;
4,POINTDOT,COLORWHITE;
5,POINTDOT,COLORFF9900;
6,POINTDOT,COLORRED;
7,POINTDOT,color00FF00;
STICKLINE(買>0,1,2,4,0),COLORYELLOW;
STICKLINE(買2>0,2,3,4,0),COLORFF00FF;
STICKLINE(買3>0,3,4,4,0),COLOR00FF00;
STICKLINE(買4>0,4,5,4,0),COLORWHITE;
STICKLINE(買5>0,5,6,4,0),COLORFF9900;
STICKLINE(買6>0,6,7,4,0),COLORRED;
DRAWTEXT(回>0 ,1 , '⊙'),COLORYELLOW;
DRAWTEXT(回2>0 ,2 , '②'),COLORFF00FF;
DRAWTEXT(回3>0 ,3 , '③'),COLOR00FF00;
DRAWTEXT(回4>0 ,4 , '④'),COLORWHITE;
DRAWTEXT(回5>0 ,5 , '⑤'),COLORFF9900;
DRAWTEXT(回6>0 ,6 , '⑥'),COLORRED;}
{以下設置主圖顯示方式}
DRAWTEXT(回>0 ,MID , '⊙'),COLORYELLOW;
DRAWTEXT(回2>0 ,MA2 , '②'),COLORFF00FF;
DRAWTEXT(回3>0 ,MA3 , '③'),COLOR00FF00;
DRAWTEXT(回4>0 ,MA4 , '④'),COLORWHITE;
DRAWTEXT(回5>0 ,MA5 , '⑤'),COLORFF9900;
DRAWTEXT(回6>0 ,MA6 , '⑥'),COLORRED;
DRAWTEXT(買>0 ,L*0.99 , '★'),COLORYELLOW;
DRAWTEXT(買2>0 ,L*0.98 , '□'),COLORFF00FF;
DRAWTEXT(買3>0 ,L*0.99 , '▲'),COLOR00FF00;
DRAWTEXT(買4>0 ,L*0.98 , '◆'),COLORWHITE;
DRAWTEXT(買5>0 ,L*0.99 , '■'),COLORFF9900;
DRAWTEXT(買6>0 ,L*0.98 , '●'),COLORRED;
DRAWTEXT(優選>0 ,L*0.97 , '優'),COLOR00FF00;
HCSJ3:=BARSLAST(回3);
ZC3:=(CROSS(C,MA3) OR CROSS(C,MA3*1.03)) AND HCSJ3<=5;
支撐點:IF(COUNT(ZC3>0,5),REF(L,HCSJ3),REF(L,HCSJ3)),
COLOR00FF00,POINTDOT,linethick1;  

上一篇文章:

下一篇文章:

 




767股票學習網 | 手機版 | 微信 | 微博 | 聯系站長





香港特码资料部