首頁 股票學校 股票入門 選股 買入 看盤 跟莊 短線 炒股技巧 技術指標 k線圖 MACD 均線 成交量 股票書籍 股票視頻 網站導航

767股票學習網 > 股票學校 > 大智慧公式 > 正文

大智慧、飛狐公式:安心操作--老鴨回頭

【老鴨回頭】-- 主副圖(原碼)
現僅以唐能通《短線是銀》一書提供的理念,精心編寫適應牛市行情的{老鴨回頭}精品指標,作為一品的一份禮物,奉獻給有緣的朋友!
指標編寫思路與信號含義:1、老鴨回頭=中線趨勢向上+短線回頭;2、坑=短線超
跌,白色特別超跌;3、買=中線趨勢向上+均線粘合+短線回升;4、優選=買+10日、20日均線通道保持向上通暢;5、逃頂=短線賣點,中線只做參考;
指標使用方法:老鴨回頭要關注,敢買深坑是高手;均線拐點是買點,通道順暢應優選。
{老鴨回頭Z---大智慧主圖}{飛狐通用}
{N:1,20,10;}
MA5:MA(C,5),COLORWHITE;
MA10:MA(C,10),COLORFF00FF;
MA20:MA(C,20),COLOR00FF00;
MA30:MA(C,30),COLORYELLOW;
MA120:SMA(C,120,1),COLOR0000FF;
ZH520:=ABS(MA5-MA20)/MA20*100<=N;
ZH530:=ABS(MA5-MA30)/MA30*100<=N;
QSXS1:=MA5>REF(MA5,1);
QSXS2:=MA20>REF(MA20,1);
QSXS3:=MA30>REF(MA30,1);
DTPL:=MA20>MA30 AND MA30>MA120;
LYHT:=DTPL AND QSXS2 AND QSXS3 AND NOT(QSXS1) AND REF(QSXS1,1);
老鴨回頭:LYHT*50,COLORFF00FF,POINTDOT,LINETHICK0;
WR5:=100*(HHV(H,5)-C)/(HHV(H,5)-LLV(L,5));
WR6:=100*(HHV(H,6)-C)/(HHV(H,6)-LLV(L,6));
WR:=80-(WR5*3+WR6*2)/5,COLORYELLOW,POINTDOT;
坑:IF(WR<0,WR,0),COLORYELLOW,POINTDOT,LINETHICK0;
LYT:=DTPL AND QSXS2 AND QSXS3 AND COUNT(QSXS1,4)<=1;
GJHS:=C>MA5 AND ((QSXS1 AND NOT(REF(QSXS1,1))) OR C>REF(C,3));
LYKK:=GJHS AND (ZH520 OR ZH530) AND LYT;
買:(LYKK AND NOT(REF(LYKK,1)))*50,COLOR00FF00,POINTDOT,LINETHICK0;
優選:(買 AND COUNT((MA10>MA20),5)=5)*100,COLORYELLOW,POINTDOT,LINETHICK0;
{以下設置主圖顯示方式}
DRAWTEXT(老鴨回頭,(MA10+MA20)/2, '●'),COLORFF00FF;
DRAWTEXT(老鴨回頭,(MA10+MA20)/2, '¤'),COLORFF00FF;
DRAWTEXT(WR<0,L*0.99, '#'),COLORYELLOW;
DRAWTEXT(WR<-10,L*0.99, '#'),COLORWHITE;
STICKLINE(買,h,l,0,1),COLOR00FF00,linethick2;
STICKLINE(買,o,c,4,1),COLOR00FF00,linethick2;
DRAWTEXT(買,L*0.99, '買★買'),COLOR00FF00;
DRAWICON(優選,L*0.99,1);
{以下設置逃頂指標}
varC:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,varC),HIGH,2);
var6:=REF(C,1);
var7:=SMA(MAX(C-var6,0),6,1)/SMA(ABS(C-var6),6,1)*100;
DRAWTEXT(CROSS(84,var7),H*1.01,'逃頂'),COLORYELLOW ;
{老鴨回頭----創幻論壇一品茶緣編寫精品指標!大智慧副圖}{飛狐通用}
{N:1,20,10;}
MA5:=MA(C,5),COLORWHITE;
MA10:=MA(C,10),COLORFF00FF;
MA20:=MA(C,20),COLOR00FF00;
MA30:=MA(C,30),COLORYELLOW;
MA120:=SMA(C,120,1),COLOR0000FF;
ZH520:=ABS(MA5-MA20)/MA20*100<=N;
ZH530:=ABS(MA5-MA30)/MA30*100<=N;
QSXS1:=MA5>REF(MA5,1);
QSXS2:=MA20>REF(MA20,1);
QSXS3:=MA30>REF(MA30,1);
DTPL:=MA20>MA30 AND MA30>MA120;
LYHT:=DTPL AND QSXS2 AND QSXS3 AND NOT(QSXS1) AND REF(QSXS1,1);
老鴨回頭:LYHT*50,COLORFF00FF;
WR5:=100*(HHV(H,5)-C)/(HHV(H,5)-LLV(L,5));
WR6:=100*(HHV(H,6)-C)/(HHV(H,6)-LLV(L,6));
WR:=80-(WR5*3+WR6*2)/5;
坑:IF(WR<0,WR,0),COLORYELLOW;
LYT:=DTPL AND QSXS2 AND QSXS3 AND COUNT(QSXS1,4)<=1;
GJHS:=C>MA5 AND ((QSXS1 AND NOT(REF(QSXS1,1))) OR C>REF(C,3));
LYKK:=GJHS AND (ZH520 OR ZH530) AND LYT;
買:(LYKK AND NOT(REF(LYKK,1)))*50,COLOR00FF00,LINETHICK2;
優選:(買 AND COUNT((MA10>MA20),5)=5)*100,COLORYELLOW,LINETHICK2;
{以下設置副圖顯示方式}
DRAWTEXT(老鴨回頭,10,'●'),COLORFF00FF;
DRAWTEXT(老鴨回頭,10,'¤'),COLORFF00FF;
STICKLINE(WR<0,WR,0,2,0),COLORYELLOW;
STICKLINE(WR<-10,WR,-10,2,0),COLORWHITE;
DRAWTEXT(買,80,'買★買'),COLOR00FF00;
DRAWICON(優選,10,1);
{以下設置逃頂指標}
varC:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,varC),80,2);
var6:=REF(C,1);
var7:=SMA(MAX(C-var6,0),6,1)/SMA(ABS(C-var6),6,1)*100;
DRAWTEXT(CROSS(84,var7),100,'逃頂'),COLORYELLOW ;
一品特別提醒:主圖加入飛狐中壓縮的太厲害----問題已經解決,原碼飛狐直接可用.  

上一篇文章:

下一篇文章:

 




767股票學習網 | 手機版 | 微信 | 微博 | 聯系站長





香港特码资料部